Orchestration Issues

Incident Report for Spiff Commerce

Resolved

We've resolved the issue & any existing unfinished executions are now being run.
Posted May 25, 2026 - 18:04 AEST

Identified

We've identified an issue causing executions to hang and are in the process of deploying a fix for the problem.
Posted May 25, 2026 - 17:00 AEST
This incident affected: Orchestration.