Platform Outage - Unprecedented Spike in Traffic

Incident Report for Spiff Commerce

Postmortem

As a result of this incident, we have taken two actions to prevent future reoccurrence.

  1. We have done an audit of customers that utilise our platform via Shopify. Using this audit, we can now confirm no one is relying on old methods of communication to notify us about changes in their Shopify store.
  2. We have dismantled the old system entirely. All new connections will be through our new system, built late last year. This system was purpose-built to handle large traffic spikes by correctly throttling requests to our server.

All partners that have installed the plugin between now and when that new system was put in place would not have been involved in this incident. Only a small subset of partners who installed within a certain time range were involved.

We apologise for any inconvenience caused by this event. We strive to ensure a reliable platform and have investigated all potential improvements we can make moving forwards to keep it that way.

Posted Jul 24, 2025 - 16:50 AEST

Resolved

At 3PM AEST on 24/7/2025, we experienced an unusually large number of requests from one of our external partners, Shopify.

During this period our database was overwhelmed and our platform became unresponsive; this behaviour is equivalent to a denial-of-service attack.
Posted Jul 24, 2025 - 15:00 AEST