Platform Performance Degradation

Incident Report for Spiff Commerce

Postmortem

Due to bulk operations communicated to us via one of our third party connections our platform was hit but a massively unexpected number of messages. This resulted in resources receiving hugely unintended amounts of traffic causing our platform to effectively become unresponsive.

We’ve put in place additional methods to catch and also throttle in situations like this moving forwards to help prevent this problem type.

We apologize for any inconvenience.

NOTE: Any orders or orchestrations expected to have run should be processed at this point and available inside the platform. If you are concerned this isn’t the case or are seeing otherwise please reach out to support@spiffcommerce.com

Posted Sep 07, 2026 - 15:22 AEST

Resolved

This incident has been resolved.
Posted Sep 07, 2026 - 15:19 AEST

Monitoring

A fix has been implemented and we're monitoring the stability of the platform
Posted Sep 07, 2026 - 12:50 AEST

Update

NOTE: This issue affects the AU region only.
Posted Sep 07, 2026 - 12:06 AEST

Identified

We're currently investigating increased server load causing pages and API calls to return errors. Note that things like orders and backend orchestration are built to handle failure and they will process in due time. Please return to this notice for further updates
Posted Sep 07, 2026 - 12:06 AEST
This incident affected: Hub, API, Workflow Experiences, File Generation, and Orchestration.